Outage across Gameball Services
Incident Report for Gameball
Postmortem

Cause: A routine automated database maintenance and minor upgrades, where an unexpected issue occurred due to a conflict between the new updates and our existing configurations..

Impact: D‌uring this time, many requests failed with 500 and 400 status.

Resolution:

  • All important orders, transactions, and events have been retried to mitigate any critical impacts on the end-users’ points and orders.
  • Automated minor upgrades are paused completely from running, until Gameball’s database configuration are updated to match changes in newer releases.
Posted Aug 04, 2024 - 17:52 EET

Resolved
Outage has been remediated, and protective measures have been applied. The issue is now resolved, and services are fully operational.
Posted Jul 29, 2024 - 19:30 EET